Extended Master Session Key (EMSK) Parameters

Created

  • 2008-06-24

Last Updated

  • 2026-03-05

Available Formats


User Specific Root Keys (USRK) Key Labels

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5295: Specification for the Derivation of Root Keys from an Extended Master Session Key (EMSK)

Available Formats

Label Description Reference
experimental1 Reserved for Experimental Use RFC 5295
experimental2 Reserved for Experimental Use RFC 5295
private1 Reserved for Private Use RFC 5295
private2 Reserved for Private Use RFC 5295
EMSK Extended Master Session Key (EMSK) RFC 5295
[email protected] Domain Specific Root Key (DSRK) RFC 5295
EAP Re-authentication Root [email protected] Re-auth usage label RFC 6696
DSRK Delivery Authorized [email protected] DSRK authorized delivery key RFC 6696
EAP Early-Authentication Root [email protected] Early authentication usage RFC 6630
[email protected] TEAP binding usage label RFC 9930

EMSK PRF Numbers

Reference

  • RFC 5295: Specification for the Derivation of Root Keys from an Extended Master Session Key (EMSK)

Available Formats

Range Registration Procedures
0-220 IETF Review
221-255 Reserved for Private Use
Value Description Reference
0 Reserved RFC 5295
1 HMAC-SHA-256 PRF+ (Default) RFC 5295
2-220 Unassigned
221-255 Reserved for Private Use RFC 5295